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Chapter 1: Introduction
Congratulations on your purchase of DrumCore! 
DrumCore is the ideal solution for anyone who 
needs professional drum parts in any style within 
seconds. Use DrumCore to dial-in the perfect beat 
for composing, arranging, remixing, or just flat 
out jamming. Since DrumCore supports AU (Mac 
only), RTAS, and VST plug-in formats, you can 
take advantage of its extensive rhythmic catalog 
as an integrated rhythm machine within your fa-
vorite DAW (such as Pro Tools®, Digital Per-
former®, Sonar®, Nuendo®, or Logic®).

Search for the perfect groove quickly and easily 
using DrumCore’s intuitive browser interface. 
DrumCore boasts of an extensive library of rhyth-
mic content recorded by professional drummers 
and percussionists of the highest calibre—such as 
Alan White (John Lennon, Yes), Terry Bozzio 
(Frank Zappa, Missing Persons), Matt Sorum (The 
Cult, Guns and Roses, Velvet Revolver), Sly Dun-
bar (Bob Marley, Peter Tosh), Zoro (Bobby Brown, 
Lenny Kravitz), and more!—using state-of-art dig-
ital and vintage recording gear in best possible 
acoustic environments. 

Furthermore, DrumCore’s catalog is expandable: 
Using DrumCore Toolkit, you can import your own 
rhythmic content, build your own DrumKits, or in-
stall additional DrumCore Drummer Packs pro-
duced by Submersible Music.
Features

DrumCore features:

• AU (Mac only), RTAS, and VST-compatibility in-
tegrates DrumCore with your favorite multi-
track audio and MIDI sequencing program (e.g., 
Pro Tools, Digital Performer, Sonar, Logic, Nu-
endo, Live, etc.).

• An extensive catalog of the highest quality 
rhythmic content. DrumCore’s database of au-
dio drum loops and hits were recorded with 
world-class drummers in state of the art stu-
dios. Each groove includes variations and fills in 
addition to the basic beats. Every groove was 
recorded at multiple tempos so that you get the 
groove you want at the tempo you want, with 
all of the artist’s nuance at each tempo and 
without the artifacts introduced by common 
time–compression and expansion algorithms. 
Most grooves in DrumCore’s database also have 
a MIDI version, which provides an even greater 
degree of flexibility in conjunction with Drum-
Core’s DrumKits.

• Factory DrumCore content is 24-bit and 48 kHz.

• Factory DrumCore content can be exported as 
REX files to your DAW to automatically match 
your project tempo. 
Chapter 1: Introduction 1
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• MIDI DrumKits—DrumCore provides multiple 
sampled DrumKits of the drummers’ kits to 
match DrumCore’s extensive collection of MIDI 
grooves. You can play DrumCore’s DrumKits 
from DrumCore’s own catalog of MIDI grooves, 
or from your DAW. Using DrumCore Toolkit, you 
can also create your own MIDI DrumKits.

• Mix and match pads from different DrumKits.

• DrumCore provides separate outputs for each 
pad of the MIDI DrumKit for independent mixing 
and processing in your DAW.

• Drag and drop files (audio and MIDI) to the Desk-
top or to any DAW that supports drag and drop 
(such as Cubase, Pro Tools, Digital Performer, or 
Logic).

• An intuitive, easy to use search engine to find 
the perfect groove, drum loop, or fill. You can 
sort loops by tempo, style, drummer, and sev-
eral other relevant criteria. Using DrumCore 
Toolkit, you can even import your own audio or 
MIDI files and provide your own metadata (in-
cluding “style” and “feel” definitions) for quick 
search and retrieval.

For information on using DrumCore 
plug-ins, see the DrumCore 3 Guide.
DrumCore Toolkit Guide
DrumCore Toolkit Features: 

• When updating to DrumCore 3, use the Import 
DrumCore Database command to import all of 
your custom content and any previously in-
stalled DrumCore DrummerPacks.

• Import DrummerPacks purchased from Sub-
mersible Music.

• The Gabrielizer™, a tool for beat manipulation, 
lets you quickly and easily reshuffle your audio 
and MIDI loops to create new unique and inter-
esting rhythms (see “Gabrielizer” on page 21).

• Using DrumCore Toolkit, you can import your 
own audio (AIF, WAV, SD II, REX, and ACID) and 
MIDI files, and provide your own metadata (in-
cluding “style” definitions) for quick search and 
retrieval.

• Edit metadata for factory and custom content 
to facilitate quick and easy “searchability.”

• Create your own custom DrumKits using your 
own drum samples.

• CoreAudio (Mac), and Direct Sound or ASIO 
(Windows) support for auditioning audio and 
MIDI grooves.

• Stand-alone MIDI capabilities for playing MIDI 
DrumKits from any MIDI controller.



                 
System Requirements
You must have Administrator Access on your com-
puter to install DrumCore. For minimum system 
requirements on Mac and Windows, see the Drum-
Core 3 Guide.

Register DrumCore
You must register DrumCore to receive your 
DrumCore authorization code. Your registration 
and authorization code will work for both the 
DrumCore plug-ins and for the DrumCore Toolkit 
application. Registered users can receive techni-
cal support by email or on the DrumCore Web site. 
The initial response time for technical support in-
quiries is within 24 hours. Registered users will 
also receive periodic software update and up-
grade notices. 
Conventions Used in This 
Guide
This guide observes the following conventions to 
indicate menu choices and key commands:
:

The following symbols are used to highlight impor-
tant information:

Convention Action

File > Import Files Choose Import Files 
from the File menu

Ctrl+I on Windows
or 
Command+I on Macin-
tosh

Hold down the Ctl key 
on Windows or the Com-
mand key on Macintosh 
and press the I key

Ctrl-click on Windows
or 
Command-click on 
Macintosh

Hold down the Ctl key 
on Windows or the Com-
mand key on Macintosh 
and click the mouse but-
ton

User Tips are helpful hints for getting 
the most out of DrumCore.

Important Notices include information 
that could affect DrumCore’s perfor-
mance.

Shortcuts show you useful keyboard or 
mouse shortcuts.

Cross References point to related sec-
tions in the guide.
Chapter 1: Introduction 3
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Chapter 2: Installation, Authorization, and 
Configuration
Installing DrumCore Toolkit
DrumCore Toolkit is installed when you install the 
DrumCore plug-ins and content. 

Authorizing DrumCore Toolkit
DrumCore plug-ins and the DrumCore Toolkit ap-
plication require an authorization code in order 
run. You must register your copy of DrumCore in 
order to receive your DrumCore authorization 
code. Your DrumCore authorization code will 
work for both the DrumCore plug-ins and the 
DrumCore Toolkit application. 

For information on installing Drum-
Core, see the DrumCore 3 Guide.

For information on authorizing Drum-
Core, see the DrumCore 3 Guide.
Cha
Configuring Audio MIDI Setup
(Macintosh Only)

DrumCore Toolkit is used as a stand-alone applica-
tion with audio playback using Apple® CoreAudio. 
CoreAudio is how Mac OS X manages audio streams 
between audio software and hardware. Most 
third-party audio hardware has drivers for 
CoreAudio. If you want to use DrumCore Toolkit 
with a third-party audio interface, you must first 
configure the Apple Audio MIDI Setup application 
(AMS) For more information, refer to Apple’s doc-
umentation.
pter 2: Installation, Authorization, and Configuration 5
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DrumCore Toolkit Preferences
Before you start using DrumCore Toolkit, you 
should configure the DrumCore Toolkit Prefer-
ences according to your preferred work habits. In 
the Preferences dialog, you can define standard 
file export and playback options. The Preferences 
dialog provides slightly different options specific 
to the Windows or Macintosh platform.

To open the Preferences dialog:

■ Launch DrumCore Toolkit:

• On Macintosh, choose DrumCore Toolkit > 
Preferences (or press Command+;). The Pref-
erences dialog opens.

• On Windows, choose Edit > Preferences (or 
press Alt+;).The Preferences dialog opens.

DrumCore Preferences, Macintosh
DrumCore Toolkit Guide
“DrumCore Data” Folder

DrumCore Toolkit expects the DrumCore Data 
folder to be in the location where it was originally 
installed. If you move the DrumCore Data folder 
to a different location, you will have to tell Drum-
Core Toolkit where to find it. When you first 
launch DrumCore Toolkit after the DrumCore Data 
folder has been moved, you will be prompted to 
locate it.

To change the location of the DrumCore Data 
folder:

1  Launch DrumCore Toolkit.

2  Open the Preferences dialog.

3  Click the Change button for the “DrumCore 
Data” folder.

4  In the Open dialog, navigate to and select a new 
location (folder).

5  Click Open.

DrumCore Preferences, Windows



                              
Export Preferences

DrumCore Toolkit provides several relevant pref-
erences for standard export options.

Export To

Use the Export To pop-up menu to specify 
whether or not you want to export files to a spe-
cific folder on your system (default) or to Cubase, 
Digital Performer, GarageBand, Logic, Nuendo, 
Pro Tools, Tracktion, or another Application.

If your DAW supports drag and drop, select your 
DAW from the Export To pop-up menu and config-
ure the rest of DrumCore’s export preferences as 
desired.

If you have any problems using Export to your ap-
plication, select “Folder” and set-up the audio 
file export settings to match your DAW project 
with the DAW’s project/session folder as the ex-
port location.

Export Location

The default folder for exported content is \Drum-
Core Data\ExportedContent\. You can change the 
default location (folder) for exported content if 
you want.

To change the location exported content:

1  Launch DrumCore Toolkit.

2  Open the Preferences dialog.

3  Click the Export Location Change button.

4  In the Open dialog, navigate to and select a new 
location (folder). 

5  Click Open.
Cha
6  To be prompted to specify the location (folder) 
for exported content every time DrumCore is 
launched, enable the Prompt for a new location 
each session option.

When dragging and dropping a file to a DAW, the 
file is converted to the export format, written as 
a new file to the specified export location, and 
then imported into your DAW.

Export Format

The Export Format Preferences let you specify the 
following audio file format options:

REC/ACID Enable the REX/ACID export option to 
have DrumCore export REX or ACID files whenever 
they are available. All of DrumCore’s factory con-
tent can be exported as REX files, or as AIFF, SD II, 
or WAVE files. 

If you have imported ACID files, they can be ex-
ported as ACID files, or as AIFF, SD II, or WAVE 
files. 

If the REX or ACID format is not available, Drum-
Core will export the file as the format selected in 
the pop-up menu (AIFF, SD II, or WAVE).

File Type AIFF, Sound Designer II, Sound Designer 
II Split .L/.R, or WAVE.

Sample Rate 44.1 kHz, 48 kHz, 88.2 kHz, 96 kHz, 
176.4 kHz, or 192 kHz.

Set the Export Location to your DAW 
project’s audio files folder. This lets 
you easily manage audio files exported 
from DrumCore that are specific to the 
project.

The Sound Designer II file format is only 
supported on Macintosh.
pter 2: Installation, Authorization, and Configuration 7
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Sample Format 16- or 24-bit.

Export Action

(Windows Only)

Notify Application

Enable the Notify Application (e.g., Pro Tools or 
Cubase) option to have DrumCore Toolkit prompt 
the specified application to automatically import 
content export from DrumCore. You must also lo-
cate and select the specified application using the 
Set Application Path button. You only need to do 
this once. If you use DrumCore Toolkit with more 
than one DAW, you will have to do this only once 
for each application.

You should set the Sample Rate and 
Sample Format (bit depth) to the same 
sample rate and bit depth as your host 
application. For example, if your 
Pro Tools session is 96 kHz and 24-bit, 
you should set DrumCore to 96 kHz and 
24-bit as well.

DrumCore factory content is all 24-bit, 
48 kHz, and is encoded in DrumCore’s 
proprietary file format.

Export Action (Windows only)
DrumCore Toolkit Guide
Export Button Action

(Pro Tools on Macintosh Only)

If Pro Tools is selected in the Export To pop-up 
menu, you can choose to Export to the Pro Tools 
Region List (Export to Pro Tools Bin), one or more 
mono tracks (Export to Pro Tools Mono Track), or 
to a stereo track (Export to Pro Tools Stereo 
Track).

If Pro Tools is not selected in the Export To pop-
up menu, the Export Button Action preferences 
are grayed out.

Export MIDI Files As Multitrack

Enable the Export MIDI files as multitrack option 
to export MIDI files with each MIDI note number as 
its own track. This is useful, if you want to sepa-
rate your drum sequence out on different tracks; 
for example, if you want the kick, snare, and ride 
on different MIDI tracks. If you prefer to have your 
MIDI drum programming all in one MIDI track, dis-
able this option.

Export Button Action (Pro Tools on Macintosh Only)



                   
DrumCore Toolkit also exports information about 
time signature and tempo. When importing Drum-
Core MIDI files into another application, different 
applications handle MIDI file import differently. 
For example, Logic will import the time signature 
and tempo as a separate MIDI track, Digital Per-
former will import the time signature and tempo 
to the conductor track. Consult the manufac-
turer’s documentation for your DAW for more in-
formation.

Exporting MIDI files to a folder, or drag-
ging and dropping the exported MIDI file 
onto MIDI tracks in your DAW (as sup-
ported by your DAW) is the most effi-
cient way to import MIDI into your 
project or arrangement.

Some applications are very specific as 
to where you can drop the file to create 
a track. When using drag and drop to 
import a DrumCore multitrack MIDI file 
into Logic or Digital Performer, you 
need to make sure there are enough 
MIDI tracks for each MIDI track from 
DrumCore, plus one extra track for the 
tempo and meter information. When 
using drag and drop to import a Drum-
Core multitrack MIDI file into Sonar, 
drop to empty space in the Arrange win-
dow (not onto an existing track) to au-
tomatically create new MIDI tracks. 
With ACID, be sure to not drop the MIDI 
file on the upper timeline as this cre-
ates a blank MIDI track with no data.
Cha
Audio Output Settings

CoreAudio

(Macintosh Only)

DrumCore will playback through CoreAudio by de-
fault. The default audio device can be configured 
using either the Apple Audio MIDI Setup or in the 
Sound Control Panel.

ASIO or DirectSound

(Windows Only)

Select the desired ASIO or DirectSound device 
from the Device pop-up menu. 

Playback Options

Auto Play on Launch

If you want DrumCore Toolkit to playback on 
launch, enable the Auto play on launch option. 
This option is disabled by default.

Autoplay on New Search

To have DrumCore Toolkit always playback the 
first item returned in a search, enable the Au-
toplay on new search option.

Stop Playback on Export

To have DrumCore Toolkit stop playback when you 
export a file, enable the Stop playback on export 
option.

DrumCore always tries to set the se-
lected ASIO device to match its internal 
sampling rate of 48 kHz. 
pter 2: Installation, Authorization, and Configuration 9
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DrumKit Options

DrumCore Toolkit plays back its DrumKit samples 
from RAM. Consequently, it needs to load the se-
lected DrumKit samples into RAM for playback. 

Preload DrumKit on Startup or Select

To have DrumCore Toolkit load the currently se-
lected DrumKit samples into RAM on launch or 
when a new DrumKit is selected, enable the Pre-
load DrumKit on startup or select option. 

If you're using DrumCore Toolkit as a MIDI Drum 
module, preloading eliminates the delay encoun-
tered when loading each sample the first time a 
particular note is played. This mode is common to 
hardware samplers in that all samples are loaded 
when a program (or patch) is selected. This takes 
longer, but then lets you immediately trigger 
sounds once the program is loaded as opposed to 
waiting for a pads sounds to load as they are trig-
gered.

DrumCore Toolkit indicates that a 
DrumKit is loading into RAM by a 
progress bar under the DrumKit Indica-
tor in the main DrumCore Toolkit win-
dow. Once the DrumKit is loaded, it dis-
plays “Fully Loaded.”

It is recommended that you do not play 
the MIDI DrumKit while a DrumKit is 
loading.
DrumCore Toolkit Guide
Keep DrumKits in Memory Once Loaded

To keep DrumKit samples loaded in RAM, even 
when switching DrumKits, enable the Keep Drum-
Kits in memory once loaded option. 

Ask to Save Changes on User DrumKits

To be prompted to save your changes when edit-
ing a DrumKit, enable the Ask to save changes on 
User DrumKits option.

When the Keep DrumKits Loaded in 
Memory Once Loaded option is enabled, 
every DrumKit selected during the 
course of a single DrumCore Toolkit ses-
sion remains loaded in RAM. Conse-
quently, this option requires the most 
memory and fastest hard drive response 
time. Some systems may encounter per-
formance problems with this option en-
abled. If you have a slower machine or 
not enough RAM available you should 
not use this option, but rather use only 
the Preload DrumKit on Startup or Se-
lect option, or just use the DrumCore 
Toolkit default option of only loading 
samples only when a pad is triggered.



Resampling Options
(Windows Only)

Fast Loading (for Preview Resampling)

For the quickest resampling response on playback 
of audio loops and fills, and MIDI DrumKits with 
ASIO, enable the Fast Loading (for preview resam-
pling) option.

Best Quality

For the best quality sample rate conversion on ex-
port, enable the Best Quality (for export resam-
pling) option. When this option is enabled, export 
may be a little slower, but DrumCore Toolkit pro-
vides high quality sample rate conversion. Dis-
abling this option results in faster exports (less 
delay when dragging and dropping), but results in 
slightly lower audio quality.
Cha
MIDI In

The MIDI In pop-up menu lets you specify any 
available MIDI port or device in your MIDI setup for 
controlling the DrumCore Toolkit DrumKit. For ex-
ample, if you have a MIDI controller, like an M-Au-
dio Trigger Finger, you can use it to play the 
DrumKit as a stand-alone drum module.

MIDI Out

The MIDI Out pop-up menu lets you specify the 
DrumCore Toolkit DrumKit module (listed as 
DrumCoreApp in the pop-up menu) or another 
available MIDI port or device in your MIDI setup. 
The DrumCoreApp is selected by default so that 
DrumCore Toolkit will playback MIDI files using its 
own DrumKit playback sampler. However, if you 
have another MIDI device in your studio you would 
like DrumCore Toolkit to use for MIDI playback, 
select the desired MIDI port or device from the 
MIDI Out pop-up menu. For example, if you really 
want to hear MIDI sequences play back using your 
vintage Simmons SDS9, you can choose to do so 
with this preference.
pter 2: Installation, Authorization, and Configuration 11
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Chapter 3: Using DrumCore Toolkit
Use DrumCore Toolkit as a stand-alone applica-
tion to import your own loops and grooves into the 
DrumCore database, create new MIDI DrumKits, 
and add or edit metadata to aid in searching items 
in the database.
DrumCore Toolkit Interface
DrumCore Toolkit provides immediate access to 
the most commonly used search controls, a 
browser-like interface to the database, playback 
and volume controls, and the Gabrielize and Ex-
port buttons.
DrumCore Toolkit User Interface

Audio Waveform/MIDI Sequence Overview Volume Meter and Slider Grooves (by category)

Category
buttons

Results
list

Audio Loops

Content Type buttons
Export
button

Gabrielize
button

Gabrielize
Settings
link

Transport

Tempo
Range
toggle

Tempo 
selector

buttons

Window resize
handle

DrumKit Indicator

Tempo
display

Queue Play
Mode toggle

MIDI Loops and Fills

and Fills
Chapter 3: Using DrumCore Toolkit 13
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Audio Waveform/MIDI Sequence Overview

The Audio Waveform/MIDI Sequence Overview 
displays an overview of the currently selected au-
dio or MIDI file for visual reference. You can also 
drag and drop from the overview to export the 
viewed audio or MIDI groove.

Volume Meter and Slider

Use the Volume slider to attenuate the main out-
put volume. The Volume meter provides a VU dis-
play of the main output level.

Category Buttons and List

Use the Category buttons to select the search cat-
egory (Drummers, Styles, or User Packs). Select 
the desired Drummer, Style, or User Pack from 
the Category List. You can create your own Drum-
mer, Style, and User Packs categories as well by 
editing the metadata for current audio and MIDI 
files or when you import files (see “Editing Meta-
data” on page 28).

Grooves List

Select the desired GrooveSet from the Grooves 
list. GrooveSets are typically grouped as a collec-
tion of beats and fills that work together (for ex-
ample, in different parts of a song arrangement).

Tempo Selector

Use the Tempo selector to find grooves at a spe-
cific tempo, or within a tempo range. When you 
select a new tempo, only audio files recorded at 
the selected tempo, or that can be played back at 
the selected tempo, appear in the Results list. 
There may be subtle differences in the same 
groove at different tempos since drummers tend 
to play differently at different tempos.
DrumCore Toolkit Guide
Tempo Range Toggle

Enable the Tempo Range toggle to search for 
grooves within a range of tempos.

Tempo Display

The Tempo Display displays the currently defined 
tempo (as indicated by the Tempo Selector). You 
can also click the Tempo Display to type the de-
sired tempo or tempo range (to a fine resolution 
of up to three decimal places).

Window Resize Handle

Click and drag the Window Resize handle to adjust 
the size of the Category, Grooves, and Results 
lists.

Results List

The Results list displays the results of a search. All 
search criteria work together, so if you apply too 
many search criteria (including extreme tempos), 
your search may return no results.

Content Type Buttons

Use the Content Type buttons to search for Audio 
or MIDI files, and Loops or Fills. The More button 
reveals an Advanced Search Criteria pane that 
provides even more search criteria (see “Ad-
vanced Search Criteria” on page 19).

Transport Buttons

Use the Transport buttons to start and stop play-
back, or to play the next or previous item in the 
Results list.

Gabrielize Button and Settings/History Link

Click the Gabrielize button to “Gabrielize,” the 
selected file. Click the Settings/History link to 
open the Gabrielizer window (see “Gabrielizer” 
on page 21).



Export Button

Click the Export button to export the selected file 
to a folder or to your favorite DAW depending on 
the settings for the Export Preferences (see “Ex-
port Preferences” on page 7).

DrumKit Indicator

The DrumKit Indicator displays the currently se-
lected DrumKit. Click the DrumKit Indicator to 
open the DrumKit Editor. For more information on 
the DrumKits Editor, see "Chapter .”

Queue Play Mode

The Queue Play Mode toggle enables (or disables) 
Queue Play Mode. When Queue Play Mode is en-
abled, you can select a second file (Audio or MIDI 
Loop or Fill) to start playback as soon as the cur-
rently selected file finishes playing. When Queue 
Play Mode is disabled, any newly selected file be-
gins playing immediately, cutting off playback of 
the previously selected file.

A Note about DrumCore 
Content
DrumCore’s extensive database of drum loops 
were recorded with world-class drummers in state 
of the art studios. Most grooves include variations 
and fills in addition to the basic beats. Every 
groove was recorded at multiple tempos so that 
you get the groove you want at the tempo you 
want, with all of the artist’s nuance at each 
tempo and without artifacts that can be intro-
duced by common time–compression and expan-
sion algorithms. All audio files are 24-bit, 48 kHz 
stereo in DrumCore’s proprietary file format 
(.czf).
Most grooves in DrumCore’s database also have a 
MIDI version, which provides an even greater de-
gree of flexibility in conjunction with DrumCore’s 
DrumKits. All MIDI files are stored in DrumCore’s 
proprietary file format (.cmf). 

DrumCore’s content is organized according to the 
most relevant metadata. You can search and sort 
DrumCore’s content in DrumCore Toolkit by 
Drummer, by Style, or by User Pack, and by tempo 
and groove. You can also search and sort grooves 
for the audio or MIDI version, as well as for loops 
and fills.

DrumCore’s grooves are divided into audio loops 
and fills, and MIDI loops and fills. In DrumCore 
Toolkit, audio loops are displayed with a square 
icon, audio fills are displayed with a diamond 
icon. MIDI loops are displayed with a circle icon, 
and MIDI fills have a diamond within the circle 
icon.

In addition to being able to use DrumCore’s cata-
log of grooves at the tempos they were originally 
recorded, most grooves can be exported as REX, 
AIFF, SD II, or WAVE files at virtually any tempo 
you want. 

Audio and MIDI Loops and Fills

Selected
Audio
Loop

Audio
Fill

MIDI
Loop

MIDI
Fill
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Factory DrumCore grooves that can be exported 
as REX files are indicated by “CFX” on the groove 
icon. Any custom REX files that you have imported 
using DrumCore Toolkit are indicated by “REX” on 
the groove icon. Custom ACID files that you have 
imported using DrumCore Toolkit are indicated by 
“ACID” on the groove icon. Any other file formats 
(AIFF, SD II, or WAVE) are not uniquely identified.

You can also search individual hits from Drum-
Core’s sampled DrumKits. Hits are displayed with 
an octagonal icon. To search for hits, use Drum-
Core’s advanced search criteria, Single Hit (see 
“Advanced Search Criteria” on page 19).

Content from earlier versions of Drum-
Core (including your own custom loops 
or version 1.x DrummerPacks) do not 
support stretchy tempos and cannot be 
exported as REX files. These appear in 
the Results list without the “CFX “indi-
cation. If you select one of these 
grooves, it will only play back and can 
only be exported at its original tempo.

Audio Hits

Selected
Audio

Hit
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Searching the Database
Use DrumCore Toolkit to search the database to 
find the right groove. You can choose to search by 
Category (Drummers, Styles, or User Packs) and 
Tempo, and you can choose to search for audio or 
MIDI loops and fills. You can even import your own 
audio or MIDI files and provide your own metadata 
for quick search and retrieval.

To search the DrumCore database using 
DrumCore Toolkit:

1  Click the desired Category button: Drummers, 
Styles, or User Packs.

2  Based on the selected Category, choose the de-
sired Drummer, Style, or User Pack from the Cat-
egory list. For example, Drummers > Sly Dunbar.

3  Based on the selected Drummer, Style, or User 
Pack, select the desired groove from the Grooves 
list. For example, Styles > Alternative > JA Psy-
cho.



4  For audio loops and fills, use the Tempo selector 
to dial-in grooves recorded at the desired tempo, 
or within a range of tempos. (All of DrumCore’s 
audio loops and fills were recorded at multiple 
tempos to retain the individual drummer’s artistic 
nuance at different tempos.)

For CXF files and MIDI grooves, use the Tempo se-
lector to control the playback tempo of the se-
lected CFX file or MIDI sequence.

5  Select the desired Content Type buttons to find 
Audio or MIDI (or both) Loops or Fills (or both). For 
example, if you only want to find audio loops, se-
lect the Audio and Loops buttons, and deselect 
the MIDI and Fills buttons.

Tempo selector

For more information about the Tempo 
selector, see “Tempo Selector” on 
page 18.

Content Type buttons, Audio and Loops selected

If neither Audio or MIDI is selected, or if 
Audio is selected and neither Loops or 
Fills are selected, any search will gener-
ate no results.
6  Click the More button for advanced search cri-
teria (see “Advanced Search Criteria” on 
page 19).

7  Select the desired Audio Loop, Hit, or Fill, or 
MIDI sequence from the Results list. Audio Loops 
appear as a square icon with a waveform, Audio 
Fills appear as a diamond icon with a waveform, 
and MIDI sequences appear as five-pin DIN circle 
icons (like a standard MIDI cable connector).

As a visual reference, the waveform for the se-
lected audio file, or a piano roll–style representa-
tion of the selected MIDI file, will be displayed in 
the Audio Waveform/MIDI Sequence Overview.

Search Results: Audio and MIDI Loops and Fills=

Use the Up and Down or Left and Right 
Arrow keys to select the previous or 
next item in the Category, Groove, or 
Results lists.

Use the Tab key to navigate between 
the Category, Groove, or Results lists.

Audio Waveform Overview

MIDI Sequence Overview

Selected
Audio
Loop

Audio
Fill

MIDI
Loop

MIDI
Fill
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By default, Audio and MIDI Loops and Fills play 
back when selected in the Results list or when a 
new search returns a result. You can start and 
stop playback of any selected item using the 
Transport controls (see “Playback Controls” on 
page 20). 

Once you have found the groove you want, you 
can simply play along with it, modify it using the 
Gabrielizer, or export it for use in another audio 
or MIDI application.

Tempo Selector

Use the Tempo selector to find an audio loop or 
fill at a specific tempo, or within a specified 
tempo range. For CFX and MIDI files, the Tempo 
selector determines the playback tempo of the 
CFX file or MIDI sequence.

The Results list will display all items in the data-
base that match the search criteria for the speci-
fied tempo or tempo range. DrumCore always lists 
audio files with the closest matching tempo 
(rounding up). CFX audio (which can be exported 
as REX or ACID files) plays back at the selected 
tempo. If a tempo range is selected, CFX audio 
plays back at the original tempo if it falls within 
the specified range. 

Non-CFX audio (which cannot be exported as REX 
or ACID files) plays back at its originally recorded 
tempo. These files (AIF, WAV, or SD II) only appear 
in the Results list if there is an exact tempo 
match.

MIDI sequences play back at the selected tempo. 
If a tempo range is selected, MIDI plays back at 
the original tempo if it falls within the specified 
range.

Press the Spacebar to start and stop 
playback.
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To specify a tempo:

■ Click and move the Tempo selector.

– or –

Click the Tempo display and type the desired 
tempo to as many as three decimal places (e.g., 
133.333).

To specify a tempo range:

1  Enable the Tempo Range toggle. The Tempo se-
lector will split.

2  Set the slowest tempo and the fastest tempo of 
the desired tempo range.

– or –

Click the Tempo display and type the desired 
tempo range (e.g., “112-118”).

Alt+“+/–” on Windows, or Com-
mand+“+/–” on Macintosh, increments 
or decrements the tempo by single dig-
its.

Tempo selector, Tempo Range toggle enabled

Tempo Range
toggle

Slowest tempo

Fastest tempo

All tempos setting

Out of range (in Red)



All Tempos Setting

The All tempos setting displays all items in the da-
tabase that match the search criteria at all avail-
able tempos. When the All tempos setting is se-
lected, audio files and MIDI sequences play back 
at the originally recorded tempo. For example, if 
the selected audio file or MIDI sequence was orig-
inally recorded at 120 bpm, it will playback at 120 
bpm.

Out of Range Tempos

DrumCore Toolkit supports exporting REX and 
ACID files, which can be exported at any tempo 
from 40 to 240 bpm. To achieve the highest possi-
ble sound quality, DrumCore Toolkit will always 
use the nearest original tempo for the REX or ACID 
file to be exported. However, some tempos may 
be far from any available original tempo and con-
sequently might not have the best possible sound 
quality at the selected tempo. For example, you 
may want a specific type of groove at 180 bpm, 
but based on the selected search criteria, the 
closest tempo match for that groove may be 120 
bpm. In that case, if you export the groove as a 
REX file at 180 bpm, it may not provide as good a 
sound quality as if you were to export the file at 
123 bpm for example. Tempos that are out of 
range are indicated in red on the tempo selector, 
and in the file name above the Waveform display 
and in the Results list.

For grooves in the database that are not stored as 
CFX, or imported REX or ACID files (such as version 
1.x DrummerPacks), only those files that exactly 
match the selected tempo appear in the Results 
list.
Advanced Search Criteria

In addition to the essential search criteria pro-
vided in the main DrumCore Toolkit window, you 
can click the More button to reveal an additional 
pane of advanced search criteria.

The Advanced Search pane lets you search by Feel 
(e.g., Shuffle or Triplet), Single Hit (e.g., Kick or 
Snare), File Type (e.g., AIF), File Name, Com-
ment, or Meter (e.g., 4/4 or 6/8). These search 
categories are part of the metadata associated 
with every file in the database. For more informa-
tion on creating and editing metadata for audio 
and MIDI files in DrumCore, see “Editing Meta-
data” on page 28.

To search by advanced criteria:

1  Click the More button in the DrumCore Toolkit 
window to reveal the Advanced Search Criteria 
pane.

2  Select the desired criteria from one of the pop-
up menus, or type a keyword in the File Name or 
Comment fields.

All matching results are displayed in the Results 
list.

Advanced Search pane
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Playing Back Audio and MIDI
DrumCore Toolkit plays back audio files using 
CoreAudio on Macintosh, or ASIO or DirectSound 
on Windows. DrumCore can play back MIDI files 
using its own sampled DrumKits or other MIDI de-
vices. For more information on using DrumCore’s 
sampled DrumKits, see "Chapter .”

Playback Controls

DrumCore Toolkit provides the necessary play-
back controls for auditioning your search results. 
By default, the first item in the Results list plays 
back automatically. The Autoplay on new search 
feature can be disabled (or enabled) in the Drum-
Core Preferences dialog (see “DrumCore Toolkit 
Preferences” on page 6).

To start or stop playback:

1  Search for the desired audio or MIDI file (see 
“Searching the Database” on page 16).

2  Select the desired item in the Results list.

3  Click the Play button (or press the spacebar).

To audition the preceding item in the Results 
list:

■ Click the Previous button (or press the Left or 
Down arrow).

To audition the next item in the Results list:

■ Click the Next button (or press the Right or Up 
arrow).

Previous, Play, and Next buttons
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Volume Controls

DrumCore Toolkit provides volume controls to 
make sure you get the right balance when playing 
back audio loops and the MIDI DrumKit sample 
player, as well as control over the main output. 

Volume

Use the Volume slider in the DrumCore Toolkit 
window to attenuate DrumCore’s main outputs.

Relative Volumes

Use the Relative Volumes window (Windows > Set 
Relative Volumes) to attenuate the playback vol-
umes of audio loops and fills, and the MIDI Drum-
Kit sample player. This way you can make sure 
that the MIDI DrumKit sample player plays back at 
the same volume as DrumCore’s audio loops. The 
default attenuation is –3 dB for both.

Volume slider and VU meter

Relative Volumes window



Gabrielizer
The Gabrielizer provides a powerful tool for cre-
ating new rhythms from existing audio and MIDI 
grooves. One click of the Gabrielize button and 
DrumCore Toolkit intelligently shuffles beats to 
come up with completely new and exciting 
rhythms. For more control, use the Gabrielizer 
window to let you quickly and easily create any-
thing from subtle variations of the original rhythm 
to completely scrambling it beyond recognition.

To “Gabrielize” a groove:

1  Conduct a search according to your desired cri-
teria.

2  Select an audio or MIDI file from the Results list.

3  Click the Gabrielize button (press Ctrl+L on Win-
dows or Command+L on Macintosh). 

Based on the Gabrielize settings, the rhythmic 
pattern of the selected audio or MIDI file will be 
reshuffled, or “Gabrielized.” 

It may be possible to overdrive the out-
put of the MIDI DrumKit when using cus-
tom imported samples. Attenuate the 
MIDI Loops Relative Volume fader to 
avoid distortion (clipping).

Gabrielize button with Settings/History link
Gabrielizer Window

For more control over the Gabrielize function, 
open the Gabrielizer window.

To open the Gabrielizer window:

■ Choose Window > Show Gabrielizer Window 
(press Command+Option+G on Macintosh or 
Ctrl+Shift+G on Windows).

– or –

Click the Settings/History link above the Gabriel-
ize button in the DrumCore window.

Settings

The Gabrielizer window provides controls over the 
application of the Gabrielizer’s internal rules for 
intelligent beat shuffling. You can apply any one 
of thirteen rules specifically, or choose to apply 
any one to eight rules randomly.

To adjust the Gabrielizer Settings:

1  Open the Gabrielizer window (Window > Show 
Gabrielizer Window).

2  Select the Apply Specific Rule Each Time option 
or the Apply Random Rules Each Time option.

Gabrielizer window
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3  Adjust the corresponding slider to apply any one 
of thirteen specific rules, or to randomly apply 
any one to eight rules.

History

The Gabrielizer window provides a history of up to 
the last eight Gabrielized grooves. As soon as you 
Gabrielize a ninth time, the first item in the his-
tory is overwritten. The Gabrielizer History will 
continue to cycle through the eight slots each 
time you Gabrielize.

To select one of up to eight of the last 
Gabrielized grooves:

1  Open the Gabrielizer window (Window > Show 
Gabrielizer Window).

2  In the History pane, click the desired item.

Clearing a Gabrielized File

If you Gabrielize a file and decide the result is not 
really what you want, you can clear the Gabriel-
ized file and return to the original file. However, 
note that the Gabrielized version will remain in 
the Gabrielizer’s History.

To clear a Gabrielized file:

■ Choose Window > Clear Gabrielized File.

Gabrielizer History pane

Click any item in the
History pane to select

and audition

Click the
Clear link

to clear the
History pane
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Saving and Importing or Exporting

In the Gabrielizer window you can save the cur-
rent Gabrielized groove and import into the Drum-
Core database. you can also export the current 
Gabrielized groove for use in third-party audio or 
MIDI application.

To save and import a Gabrielized groove:

1  Choose Window > Save Gabrielized File (or press 
Command+S on Macintosh or Ctrl+S on Windows). 
The Save Gabrielized File dialog opens. 

– or –

Open the Gabrielizer window (Window > Show 
Gabrielizer Window) and do the following:

• If necessary, select the desired Gabrielized 
groove in the History pane.

• Click the Save/Import button. The Save Gab-
rielized File dialog opens.

2  Enter or edit the metadata for the Gabrielized 
file and click Save. (For more information on cre-
ating and editing metadata for audio and MIDI 
files in DrumCore, see “Editing Metadata” on 
page 28.)

Gabrielized files cannot be imported or 
exported as REX files.

Save Gabrielized File dialog



The Gabrielized file will be saved and imported 
into the DrumCore database. You will be able to 
search for the Gabrielized file based on the meta-
data save with the file.

To export a Gabrielized groove:

■ Choose Window > Export Gabrielized File.

– or –

Open the Gabrielizer window (Window > Show 
Gabrielizer Window) and do the following:

• If necessary, select the desired Gabrielized 
groove in the History pane.

• Click the Export button. 

The Gabrielized file is exported to the default Ex-
port location as specified in the DrumCore Toolkit 
Preferences (see “DrumCore Toolkit Preferences” 
on page 6).

Exporting Audio and MIDI
Once you have found the groove you want, or cre-
ated a new one using the Gabrielizer, you will 
probably want to export it for use in your DAW. 
The export behavior for DrumCore Toolkit de-
pends on the settings in the DrumCore Toolkit 
Preferences (see “DrumCore Toolkit Preferences” 
on page 6). The Export button updates to show 
whether the file will be exported to a folder or to 
another application. For example, if the Drum-
Core Toolkit Preferences are set to export to a 
folder, the Export button will display “EXPORT to 
FOLDER.” If the DrumCore preferences are set to 
export to Logic, the Export button will display 
“EXPORT TO LOGIC.”
Files are exported in the file format, sample rate, 
and bit-depth specified in the DrumCore Toolkit 
Preferences.

Exported files include the tempo at beginning of 
the file name. For example, if you export a file at 
92 bpm, the exported file is named “092<file-
name>.” If the tempo is not already part of the 
file name, DrumCore Toolkit adds it automati-
cally. However, REX and ACID files will always 
have their own native tempo, which may not cor-
respond to the selected tempo in DrumCore Tool-
kit. Consequently, DrumCore Toolkit does not 
prepend the tempo to REX and ACID file names.

To export an audio or MIDI file from DrumCore:

1  Set the DrumCore Toolkit Export Preferences as 
desired (see “DrumCore Toolkit Preferences” on 
page 6).

2  Search for and select the desired file.

3  Click the Export button (or press Command+E on 
Macintosh or Ctrl+E on Windows).

The selected file is exported to the folder desig-
nated in the DrumCore Toolkit Preferences. By 
default, this will be the ExportedContent folder in 
the DrumCore Data folder. In addition to changing 
the directory location for exported files using the 
Preferences dialog, you can use the Set Export Lo-
cation from the Export menu.
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To change the export location:

1  Choose Export > Set Export Location. The Verify 
Export Location dialog opens.

2  Click the Change button.

3  In the resulting Open dialog, create a new 
folder, or navigate to an existing folder, and click 
Choose.

4  In the Verify Export Location dialog, click OK.

Verify Export Location dialog
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Export by Drag and Drop

DrumCore Toolkit also supports drag and drop for 
export of audio and MIDI files. You can easily drag 
and drop a file from the Results list to the desktop 
or to an application that supports drag and drop 
for import, such as Ableton Live or Digital Per-
former. When dragging and dropping to your DAW, 
DrumCore Toolkit will first export the file to the 
default export location (as specified in the Pref-
erences dialog).

When exporting REX or ACID files from 
DrumCore Toolkit to Pro Tools 
(Pro Tools 7.0 or later only), be sure to 
export them to the Pro Tools Regions 
List or drag and drop to a Tick-based 
track.
Figure 1.  Drag and drop from DrumCore to Digital Performer



Importing Audio and MIDI
In addition to using the content that comes with 
DrumCore, you can also import your own content 
using DrumCore Toolkit. So if you already have 
your own library of samples and loops, you can im-
port them into the DrumCore database and take 
advantage of DrumCore’s search engine and AU, 
RTAS, or VST plug-in integration.

DrumCore Toolkit lets you import AIF, WAV, SD II 
(16- and 24-bit), and REX 2 and ACID files. The in-
ternal tempo of imported REX or ACID files is used 
within DrumCore, and is maintained on export. 
User imported REX and ACID files are indicated in 
the Results list by “REX” or “ACID” on the groove 
icon in DrumCore Toolkit.

To import an audio or MIDI file using DrumCore 
Toolkit:

1  Move or copy the audio or MIDI files (or a folder 
containing multiple audio or MIDI files) that you 
want to import into the DrumCore Content folder.

If you try to import files that are not in the Drum-
Core Content folder, you will encounter an error 
message informing you that you need to copy the 
files to the DrumCore Content folder.

2  Choose File > Import Files (or press Command+I 
on Macintosh or Ctrl+I on Windows). The Import 
Files dialog opens.
3  If the files you want to import follow the naming 
convention of starting with a bpm value (e.g., 
120filename or 092filename), DrumCore Toolkit 
can infer the bpm value for each file.

4  Click the Choose Folder button to select a folder 
containing all the files to be imported.

– or –

Click the Choose One File button to select a single 
file for import.

5  In the resulting Open dialog, navigate to and se-
lect the folder or file you want to import and click 
Choose.

6  Enable the corresponding checkbox for each 
field you want to edit.

7  Enter or select the relevant metadata to be as-
sociated with the imported files. 

Import Files dialog
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8  If a particular item is not available within one of 
the pop-up menus, you can select New from the 
pop-up menu to add the required information. For 
example, if you have a loop that is one bar of 
13/16:

• Select New from the Meter pop-up menu.

• Type “13/16” in the New Value dialog.

• Click OK.

9  Once you have entered all the necessary infor-
mation, click the Import button.

10  The Importing Files Progress window will ap-
pear and displays whether or not the import was 
successful. Once the import has completed suc-
cessfully, click OK.

Each imported file is added to the DrumCore da-
tabase, and you will be able to search for any im-
ported file based on DrumCore’s standard criteria 
and the file’s associated metadata.

New Value dialog

New Value dialog
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Importing DrumCore Databases
Use the Import DrumCore Database command to 
import content from other DrumCore databases. 
For example, if you are upgrading your version of 
DrumCore from an earlier version, you may want 
to import some of your old content (such as cus-
tom content or version 1.x DrummerPacks).

To import DrumCore content:

1  In DrumCore Toolkit, choose File > Import Drum-
Core Database. The Import DrumCore Content di-
alog opens.

Import DrumCore Content dialog



2  Click the Select button to navigate to the direc-
tory containing the desired DrumCore content.

3  Select the desired directory and click Choose.

4  In the Import DrumCore Content dialog, select 
one of the following from the pop-up menu for Ex-
ported Files, User Content, DrummerPacks, and 
DrumKits as necessary:

• COPY Files and Import

• MOVE Files and Import

• IGNORE (Do Not Import)

5  Click Import.

The Importing “DrumCore Data” dialog reports 
the progress of the import. 

6  When the import is done, click OK.

Importing “DrumCore Data” dialog
Deleting Items
DrumCore Toolkit lets you permanently delete da-
tabase files from the DrumCore database. This en-
sures that the file will not show up in any search. 
However, deleting an item only purges it from the 
database; it does not delete any audio or MIDI 
files from disk.

To delete any selected item from the DrumCore 
database:

1  Using DrumCore Toolkit, search for the item you 
want to delete from the DrumCore database.

2  Select the item in the Results list.

3  Choose Edit > Delete Selected Items.

4  In the resulting Delete Records dialog, click Yes.

The selected item will be permanently deleted 
from the DrumCore database.

In the Results list, you can Shift-click to 
select multiple contiguous items, or 
Command-click on Macintosh or Ctrl-
click on Windows to select multiple dis-
contiguous items.

Delete Records dialog
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Editing Metadata
DrumCore’s database and search engine rely on 
metadata associated with each file in the data-
base to help you find the desired file quickly and 
easily. You may want to edit the metadata for 
certain files to help you streamline your workflow 
and refine your searches. Using DrumCore Toolkit, 
you can create new metadata for files you import 
(see “Importing Audio and MIDI” on page 25), or 
you can add or edit metadata for files already in 
DrumCore’s database.

To edit metadata for a file:

1  In DrumCore Toolkit, conduct a search and se-
lect the file you want to edit in the Results list.

2  Choose Edit > Edit Selected Item (press Com-
mand+M on Macintosh or Ctrl+M on Windows). The 
Edit Records dialog opens.

In the Results list, you can Shift-click to 
select multiple contiguous items, or 
Ctrl-click on Windows or Command-click 
on Macintosh to select multiple discon-
tiguous items.

Edit Records dialog
DrumCore Toolkit Guide
3  Enable the corresponding checkbox for the each 
field you want to edit.

4  Enter or select the relevant metadata. 

5  If a particular item is not available within one of 
the pop-up menus, you can select New from the 
pop-up menu to add the required information. For 
example, if you have a loop in a hard rock style 
and you want to categorize the feel as “heavy:” 

• Select New from the Feel pop-up menu.

• Type “heavy” in the New Value dialog.

• Click OK.

6  Once you have entered all the necessary infor-
mation, click the Save Settings button.

7  You will be prompted to confirm your changes. 
Click Yes to save your changes and permanently 
alter the record, or click No to cancel.

New Value dialog



CHAPTER 4: THE DRUMKIT EDITOR
In addition to its extensive library of audio loops 
and fills by some of the world’s best drummers, 
DrumCore provides a MIDI drum module with mul-
tiple sampled kits of the same Drummers. Drum-
Core’s MIDI groove library plays these kits by de-
fault. In addition to using DrumCore’s “factory” 
DrumKits, you can edit them or even create your 
own custom kits using DrumCore Toolkit.

DrumCore’s DrumKits were created by the original 
drummer’s strikes using the same or similar drums 
used in their audio loops. DrumKits have been op-
timized to work with various drummer’s MIDI 
grooves (included in their respective User Packs). 
Be sure to select the corresponding DrumKit to 
match a drummer’s MIDI grooves. You can also try 
switching kits for some interesting variations 
(such has playing Tony Braunagel’s Vintage kit 
with one of Sly Dunbar’s MIDI grooves).

You can play the MIDI DrumKits in DrumCore Tool-
kit using a MIDI sequencer or with an external MIDI 
controller. To play DrumCore’s MIDI Drum mod-
ule, simply select the corresponding MIDI port or 
device in the MIDI In pop-up menu in the Drum-
Core Toolkit Preferences window (see “MIDI In” on 
page 11).
DrumKits

To open the DrumKits window:

■ Choose Windows > DrumKit Editor. The DrumKits 
window opens.

To select a DrumKit:

■ Select the desired DrumKit from the DrumKits 
menu.

– or –

Open the DrumKits window and select the desired 
DrumKit from the Current Kit pop-up menu.

DrumKit Editor window (Drums tab)

Current Kit pop-up menu
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DrumCore Toolkit loads the samples for the se-
lected DrumKit into RAM, so, depending on the 
speed of your CPU and your RAM, this can take 
several seconds. As soon as you switch DrumKits, 
DrumCore Toolkit purges the previous kit from 
RAM and loads the new one. 

In the DrumCore Toolkit Preferences, you can 
choose to have DrumCore Toolkit preload the cur-
rent DrumKit on start up or when selected, as well 
as keep it loaded in RAM when switching between 
kits (see “DrumCore Toolkit Preferences” on 
page 6).

DrumCore Toolkit indicates that a DrumKit is load-
ing into RAM by a progress bar under the DrumKit 
Indicator in the main DrumCore Toolkit window. 

Loading DrumKit progress bar

It is recommended that you do not play 
the MIDI DrumKit while a DrumKit is 
loading.
DrumCore Toolkit Guide
Kit Settings

The DrumKits window provides a LiveDrummer 
slider and a Kit Volume slider. 

LiveDrummer

Whether you are programming your own MIDI 
drum patterns or using DrumCore’s MIDI grooves, 
you can use the LiveDrummer slider to add a little 
variety to the sound. The LiveDrummer slider af-
fects both the velocities and the samples used for 
each event. For example, if you add a series of 
MIDI notes that are all at the same velocity to play 
a hi-hat pad, you can adjust the LiveDrummer 
slider to breathe a little life into it. Experiment 
with this setting to find just the right feel for your 
MIDI grooves and drum patterns.

Volume

To adjust the Kit Volume:

■ Move the Kit Volume slider to the right to boost 
the Kit volume.

– or –

■ Move the Kit Volume slider to the left to atten-
uate the Kit Volume.

Kit Settings



Playing DrumKits
You can play the DrumKit in any one of three 
ways:

• DrumCore’s MIDI files will playback using the 
DrumCore DrumKit by default. 

• Assign MIDI track outputs in your DAW to play 
DrumCore Toolkit using a virtual MIDI node (such 
as using IAC on Mac). Select the corresponding 
virtual MIDI node in the DrumCore Toolkit Pref-
erences (see “MIDI In” on page 11).

• Play DrumKits using an external MIDI controller. 
Simply assign the MIDI port or device for your 
controller in the DrumCore Toolkit Preferences 
(see “MIDI In” on page 11).

Audio does not play back until a Drum-
Kit or pad is loaded. If your computer is 
fast enough and has enough RAM, en-
able the Preload DrumKit on Startup or 
Select preference (see “DrumKit Op-
tions” on page 10). This makes it easier 
to quickly audition MIDI as well as audio 
content.
DrumKit Pads
The DrumKits window displays the “pad” assign-
ments for the selected kit as Pad Settings and Kit 
Settings. There are two pages of pads: Drums 
(MIDI note numbers 35–58) and Percussion (MIDI 
note numbers 59–82). Click either the Drums or 
Percussion tabs to display the corresponding set 
of Pads.

Each Pad represents a specific drum or sound in 
the kit. Each Pad displays the note name that trig-
gers the Pad, the Pad name, and Mute and Solo 
buttons for the Pad.

DrumKits window (Percussion tab)

DrumKit Pad

Note Name

Pad Name

Pad Mute Pad Solo
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To select an individual Pad:

■ Click a any Pad to select it.

To play an individual Pad:

■ Play any Pad by clicking it.

– or –

Play the corresponding MIDI note on your MIDI con-
troller.

– or –

If a Pad is selected, press Control+Spacebar on 
Macintosh or Ctrl+Spacebar on Windows.

To mute or unmute an individual Pad:

■ Click the Pad’s Mute button.

To solo or unsolo an individual Pad:

■ Click the Pad’s Solo button.

Pad Settings

You can change the name, attenuate the volume, 
adjust the pan, change the pitch, or edit the sam-
ple layers for any selected Pad.

Use the Up, Down, Left, and Right Ar-
row keys to select the corresponding 
adjacent Pad.

Pad Settings

Pad Name
(link)

Edit Sample
Layers button

Pad Volume
slider

Pad Pitch
slider

Pad Pan
slider
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To change the name of a Pad:

1  Select the desired Pad.

2  Click the Pad Name in the Pad Settings pane. 
the Pad Name Editor dialog opens.

3  Type the new Pad name and click OK.

To attenuate the volume of a Pad:

1  Select the desired Pad.

2  In the Pad Settings pane, adjust the Pad Volume 
slider to the desired level.

To adjust the panning of a Pad:

1  Select the desired Pad.

2  In the Pad Settings pane, adjust the Pad Pan 
slider to the desired level.

Panning to a stereo output pans between the left 
and right output channels. Panning to a mono out-
put mixes between the left and right channels of 
stereo DrumCore samples.

To change the pitch of a Pad:

1  Select the desired Pad.

2  In the Pad Settings pane, adjust the Pad Pitch 
slider to the desired level.

Pad Name Editor dialog

For Volume, Pan, and Pitch, you can 
click the name of the control to restore 
the default setting.



Pad Swapping

You can quickly and easily swap pads between 
DrumKits. For example, let’s say you want to use 
Terry Bozzio’s snare in one of Alan White’s kits, 
simply Right-click the snare pad in Alan White’s 
kit and select Terry Bozzio’s snare. 

To swap a Pad from another DrumKit:

1  Select the DrumKit with which you want to 
start.

2  Right-click the Pad you want to swap out.

3  From the resulting pop-up menu, select the 
DrumKit whose pad you want to use.

Pad Sample Layers

Every pad consists of up to 32 sample layers. Each 
sample layer is triggered by a specified range of 
MIDI velocities, and each can be crossfaded with 
the next layer. This allows for much more realistic 
and nuanced acoustic dynamics than simply in-
creasing or decreasing the sample playback vol-
ume according to different MIDI velocities. For ex-

On Mac, Ctrl-click any pad for the Re-
place With pop-up menu.

Right-click pop-up menu for Pad swapping
ample, a snare drum played loudly has a very 
different distribution of energy across the acous-
tic spectrum than does a snare drum that is played 
softly. DrumCore’s “factory” DrumKits provide 
various sample layers for each Pad to provide the 
most acoustically viable MIDI playback possible.

In the Edit Sample Layers window, DrumCore 
Toolkit provides a great deal of control over the 
configuration of sample layers for each Pad. Edits 
are not applied until you close the Edit Sample 
Layers window.

To edit the sample layers for a Pad:

1  Using the DrumKit Editor in DrumCore Toolkit, 
select the desired Pad.

2  Click the Edit Sample Layers button (or press 
Enter). The Edit Sample Layers window opens.

Edit Sample Layers window
Chapter 4: The DrumKit Editor 33



34
3  Click any Sample Layer to select it. 

4  If desired, move the Attenuation slider to adjust 
the playback volume of the selected Sample 
Layer.

5  To audition a sample layer, simply click it. 

– or –

To audition a sample layer or crossfade played at 
a particular velocity, click the Velocity scale to 
the left of a sample layer or crossfade.

6  If desired, click and drag the Crossfade Amount 
handle to adjust the length of the equal-power 
crossfade between any two adjacent Sample Lay-
ers. The area of the crossfade between the two 
Sample Layers will increase or decrease according 
to whether you move the Crossfade handle up or 
down.

7  If desired, click and drag the Crossover Point 
handle to adjust the MIDI velocity range for trig-
gering the Sample Layer.

Sample Layers with crossfades

Crossfade 
handle

Crossfade 
area

Crossover
Point handle

MIDI Velocity scale
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8  If desired, click the Add Layer button to add 
new Sample Layer to the Pad. Navigate to and se-
lect the desired audio file (AIFF, SD II, or WAVE), 
and click Choose. The new Sample Layer will be 
added following the selected Sample Layer, or af-
ter the last (softest) Sample Layer if no Sample 
Layer is selected.

– or –

You can drag and drop samples from the desktop 
to create new sample layers.

9  If necessary, you can drag sample layers within 
the Edit Sample Layers window to reorder them.

10  If desired, click the Remove Layer button to 
remove the selected Sample Layer from the Pad.

11  If desired, click the Remove All Layers button 
to remove all of the Sample Layers from the Pad 
and start from scratch.

12  When you have finished editing the Sample 
Layers for a Pad, click the OK button.

Dragging and dropping an audio file from the 
Desktop to a sample layer in DrumCore



Creating Custom DrumKits
The DrumKit Editor in DrumCore Toolkit is vital to 
anyone used to working with drum machines or 
drum sample libraries. The DrumKit Editor pro-
vides an easy way to manage and recall your en-
tire drum sample library from your computer, 
conveniently organized as DrumCore DrumKits.

To create your own DrumKit:

1  Launch DrumCore Toolkit.

2  Select DrumKits > New. The New DrumKit dialog 
opens.

3  Type the name for the DrumKit in the New Name 
field.

4  Select New Empty DrumKit to start from 
scratch.

– or –

Select Existing DrumKit and the desired DrumKit 
from the pop-up menu to work from an existing 
DrumKit.

5  Click Save to save your changes to the current 
DrumKit. 

6  Edit the DrumKit as desired.

New DrumKit dialog
7  Choose DrumKits > Save As to save your edits as 
a new DrumKit. 

– or –

Choose DrumKits > Save to save your changes to 
an existing DrumKit.

Deleting Custom DrumKits
DrumCore Toolkit lets you delete any custom cre-
ated DrumKits.

To delete a DrumKit:

1  Launch DrumCore Toolkit.

2  Select DrumKits > Delete.

3  In the resulting dialog, select the DrumKit you 
want to delete from the DrumKit pop-up menu.

4  Click the Delete button to permanently delete 
the selected DrumKit.

Deleting a DrumKit

DrumCore Toolkit will not let you de-
lete factory DrumKits. All factory 
DrumKits are greyed out in the DrumKit 
pop-up menu.

Drum samples are not deleted when a 
DrumKit is deleted. DrumCore Toolkit 
will only let you delete the DrumKit da-
tabase file.
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