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Chapter 1: Introduction
Congratulations on your purchase of KitCore™! 
Powered by Submersible Music’s DrumCore® tech-
nology, KitCore is a virtual instrument plug-in that 
is the ideal solution for anyone who needs a pro-
fessional MIDI drum module in their AU, RTAS, or 
VST host. Use KitCore as an integrated rhythm 
machine within your favorite digital audio work-
station (DAW), such as Pro Tools®, Digital Per-
former®, Sonar®, Cubase®, Live®, or Logic ®.

KitCore features:

• The KitCore plug-in is available in AU, RTAS, and 
VST plug-in formats.

• KitCore provides an extensive library of MIDI 
drum loops, fills, and songs that can be 
searched, sorted, auditioned, imported into 
your favorite DAW.

• KitCore provides separate assignable audio out-
put channels for each pad.

• KitCore provides individual volume, pan, and 
pitch control for each pad.

• Pad swapping lets you swap samples between 
kits. For example, you can use Matt Sorum’s 
snare within John Bishop’s kit.

• If you own DrumCore®, and it is installed on 
your computer, KitCore can use DrumCore’s 
content, including any custom kits you may 
have created.
System Requirements
You must have Administrator Access on your com-
puter to install KitCore.

Minimum Requirements for Windows

• Pentium® PIII or AMD Athlon® 800 MHz 
processor or faster

• 512MB RAM, 1 GB or more recommended

• 500 MB of available drive space for KitCore or 
2.5 GB of available drive space for KitCore De-
luxe (for content)

• DVD ROM Drive (for installing KitCore Deluxe)

• Windows XP or Vista

• 1024 X 768 minimum display resolution 

Minimum Requirements for Macintosh

• Apple® Macintosh® Power Mac® or 
PowerBook® G4 500 MHz or faster

• 512MB RAM, 1 GB or more recommended

• 500 MB of available drive space for KitCore or 
2.5 GB of available drive space for KitCore De-
luxe (for content)

• DVD ROM Drive (for installing KitCore Deluxe)

• Mac OS X (v10.3.x or later)

• 1024 X 768 minimum display resolution 
Chapter 1: Introduction 1
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Register KitCore
You must register KitCore to receive your KitCore 
authorization code. Registered users can receive 
technical support by email or on Submersible’s 
website (www.submersible.com). The initial re-
sponse time for technical support inquiries is 
within 24 hours. Registered users will also receive 
periodic software update and upgrade notices. 
Register KitCore at www.submersible.com.
KitCore Guide
Conventions Used in This 
Guide
This guide observes the following conventions to 
indicate menu choices and key commands:
:

The following symbols are used to highlight impor-
tant information:

Convention Action

File > Import Files Choose Import Files 
from the File menu

Ctrl+I on Windows
or 
Command+I on Macin-
tosh

Hold down the Ctl key 
on Windows or the Com-
mand key on Macintosh 
and press the I key

Ctrl-click on Windows
or 
Command-click on 
Macintosh

Hold down the Ctl key 
on Windows or the Com-
mand key on Macintosh 
and click the mouse but-
ton

User Tips are helpful hints for getting 
the most out of DrumCore.

Important Notices include information 
that could affect DrumCore’s perfor-
mance.

Shortcuts show you useful keyboard or 
mouse shortcuts.

Cross References point to related sec-
tions in the guide.



                             
Chapter 2: Installation and Configuration
Installing KitCore
KitCore requires at least 500 MB of available stor-
age space for the download version of KitCore, 
and at least 2.5 GB of available storage space for 
KitCore Deluxe. If you own DrumCore and it is in-
stalled on your computer, KitCore can use Drum-
Core’s content as well.

Installing KitCore on Windows

To install KitCore:

1  Do one of the following:

• For KitCore Deluxe, insert the KitCore in-
staller disc into your computer’s DVD drive.

• For KitCore, download the KitCore installer 
to your desktop.

2  Double-click the installer icon.

3  Follow the on-screen instructions to install the 
KitCore plug-in and content.

4  When installation is complete, exit the KitCore 
installer.

If own DrumCore, and it is installed on 
your computer, you can choose to only 
install the KitCore plug-in and use the 
existing DrumCore content.
KitCore installs the following:

■ KitCore RTAS plug-in:

• \\Program Files\Common Files\Digi-
design\DAE\Plug-Ins\KitCore.dpm (if 
Pro Tools is installed)

– or –

• \\Program Files\Submersible\KitCore\Plug-
Ins\RTAS (if Pro Tools is not installed)

■ KitCore VST plug-in: \\Program Files\Submers-
ible\KitCore\Plug-ins\

■ KitCore User Guide: \\Program Files\Submers-
ible\KitCore\

■ KitCore Data: \\Program Files\Submersible\Kit-
Core\
Chapter 2: Installation and Configuration 3
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Installing KitCore on Macintosh

To install KitCore:

1  Do one of the following:

• For KitCore Deluxe, insert the KitCore in-
staller disc into your computer’s DVD drive.

• For KitCore, download the KitCore installer 
to your desktop.

2  Double-click the installer icon.

3  Follow the on-screen instructions to install the 
KitCore plug-in and content.

4  When installation is complete, click Done quit 
the KitCore installer.

KitCore installs the following:

■ KitCore Audio Units plug-in: /Library/Au-
dio/Plug-Ins/Components/KitCore.component

■ KitCore RTAS plug-in: 

• /Library/Application Support/Digi-
design/Plug-Ins/KitCore.dpm (if Pro Tools is 
installed)

– or –

• If Pro Tools is not installed: /Library/Appli-
cation Support/Submersible (if Pro Tools is 
not installed)

■ KitCore VST plug-in: /Library/Audio/Plug-
Ins/VST/KitCore.vst

■ KitCore User Guide: /Applications/KitCore/Kit-
Core.pdf

■ KitCore Data: /Library/Application Sup-
port/Submersible/KitCore/KitCore Data/

If own DrumCore, and it is installed on 
your computer, you can choose to only 
install the KitCore plug-in and use the 
existing DrumCore content.
KitCore Guide
Authorizing KitCore
KitCore requires an authorization code in order to 
run. You must register your copy of KitCore in or-
der to receive your KitCore authorization code.

To authorize KitCore:

1  Launch your AU, RTAS, or VST host application 
(such as Logic, Pro Tools, or Cubase).

2  Insert KitCore on a track in your DAW, you will 
be prompted to register KitCore.

3  Click OK. The Register KitCore dialog opens.

4  Enter your Name and Serial Number (your serial 
number is located on your KitCore Registration 
card).

5  Click the Generate Challenge Code button. A 
unique “challenge” code (a series of 28 lowercase 
letters) will be generated and displayed in the 
Challenge Code field.

6  Register KitCore at www.submersiblemusic.com 
by doing the following: 

• Click the hyper link to Submersible Music’s 
secure website. 

• Your default Web browser will launch to Kit-
Core’s Product Registration page. 

• Your Name, Serial Number, and Challenge 
Code should be entered automatically. If 
not, type in your Name, Serial Number, and 
Challenge Code.

• Enter your email address (your authorization 
code will be sent to this email address).

• Click the Submit Registration button.



        
If you are unable to register KitCore using the 
DrumCore website, send an email to regis-
ter@submersiblemusic.com with your Name, Se-
rial Number, Challenge Code, and email address 
(your authorization code will be sent to this email 
address).

7  A unique “response” code (a series of 24 upper-
case letters) will be emailed to you. However, un-
til you receive your authorization code, click the 
30-Day Demo button to use KitCore.

8  When you receive your response code, enter it 
in the Response Code field and click the Authorize 
button. You can access the Register KitCore dialog 
from the KitCore Settings tab in the KitCore Plug-
in window (see “KitCore Settings” on page 16).

You must register KitCore to receive 
your authorization code.

KitCore is fully functional for the dura-
tion of the 30-day demo period. After 
30 days you must enter your authoriza-
tion code to continue using KitCore.
Chapter 2: Installation and Configuration 5
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CHAPTER 3: Using KitCore
KitCore is a virtual instrument plug-in in AU, 
RTAS, and VST plug-in formats. KitCore provides 
multiple sampled drum kits of some of the best 
drummers in the business. Select the KitCore 
plug-in in your favorite AU, RTAS, or VST host ap-
plication (such as Logic, Pro Tools, or Cubase), 
and use MIDI to play KitCore in your Digital Audio 
Workstation (DAW). KitCore uses the same stan-
dard General MIDI (GM) MIDI note mappings for all 
of its drum kits.

Refer to the manufacturer’s documen-
tation for your DAW for information on 
how to configure and use virtual instru-
ment plug-ins such as KitCore with your 
DAW.
KitCore Plug-in Window

To open the KitCore plug-in:

1  Launch your favorite DAW (such as Cubase or 
Pro Tools).

2  Insert the KitCore plug-in on a track. The Kit-
Core Plug-in window opens.

KitCore Plug-in window (Drums tab)
Chapter 3: Using KitCore 7
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To select a DrumKit:

■ Select the desired Kit from the Current Kit pop-
up menu.

KitCore loads the samples for the selected Kit into 
RAM, so, depending on the speed of your CPU and 
your RAM, this can take several seconds. As soon 
as you switch Kits, KitCore purges the previous kit 
from RAM and loads the new one. 

KitCore indicates that a DrumKit is loading into 
RAM by a progress bar that appears in the Current 
Kit pop-up menu. 

Playing KitCore
Since KitCore is a virtual instrument plug-in, you 
can play it within your DAW using sequenced MIDI 
data or in real-time by routing a external MIDI 
controller through your DAW to KitCore. KitCore 
uses the standard General MIDI (GM) note num-
bers for drum mapping. 

Current Kit pop-up menu

It is recommended that you do not play 
KitCore while a new Kit is loading into 
RAM.

For more information about configuring 
MIDI, MIDI routing, and playing virtual 
instrument plug-ins in your DAW, con-
sult the manufacturer’s documenta-
tion.
KitCore Guide
KitCore Pads
The KitCore plug-in window displays the “pad” as-
signments for the selected kit as Pad Settings and 
Global Pad Settings. 

There are two pages of pads: 

• Drums (MIDI note numbers 35–58) 

• Percussion (MIDI note numbers 59–82). 

Click either the Drums or Percussion tabs to dis-
play the corresponding set of Pads.

DrumKits window (Percussion tab)



                                   
Each Pad represents a specific drum or sound in 
the kit. Each Pad displays the note name that trig-
gers the Pad, the Pad name, a MIDI indicator, and 
Mute and Solo buttons for the Pad. The MIDI indi-
cator lights when it receives the corresponding 
MIDI note.

To select an individual Pad:

■ Click any Pad to select it.

To play an individual Pad:

■ Play any Pad by clicking it.

– or –

■ Play the corresponding MIDI note on your MIDI 
controller.

– or –

■ If a Pad is selected, press Ctrl+Spacebar on Win-
dows, or Control+Spacebar on Macintosh.

The Pad’s MIDI indicator lights when it receives 
MIDI.

To mute or unmute an individual Pad:

■ Click the Pad’s Mute button.

DrumKit Pad

Depending on your DAW, you can use 
the Up, Down, Left, and Right Arrow 
keys to select the corresponding adja-
cent Pad.

Note Name

Pad Name

Pad Mute Pad Solo

MIDI Indicator
To solo or unsolo an individual Pad:

■ Click the Pad’s Solo button.

Pad Settings

You can attenuate the volume, adjust the pan, 
and change the pitch of any selected Pad.

To adjust the volume of a Pad:

1  Select the desired Pad.

2  In the Pad Settings pane, move the Pad Volume 
slider to the left to lower the pad volume, or to 
the right to raise the pad volume.

To adjust the panning of a Pad:

1  Select the desired Pad.

2  In the Pad Settings pane, move the Pad Pan 
slider to the left to pan left, or to the right to pan 
right.

Panning to a stereo output pans between the left 
and right output channels. Panning to a mono out-
put mixes between the left and right channels of 
stereo KitCore samples.

Pad Settings

Changes to Pad Settings can be saved as 
plug-in presets in AU, RTAS, and VST 
formats. 

Pad MIDI Note Number

Pad Name

Pad Volume slider

Pad Pitch slider

Pad Pan slider
Chapter 3: Using KitCore 9
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To change the pitch of a Pad:

1  Select the desired Pad.

2  In the Pad Settings pane, move the Pad Pitch 
slider to the left to lower the pitch, or to the right 
to raise the pitch.

Pad Swapping

You can quickly and easily swap pads between dif-
ferent Kits. For example, let’s say you want to use 
Terry Bozzio’s snare in one of Alan White’s kits, 
simply right-click the snare pad in Alan White’s kit 
and select Terry Bozzio’s snare. 

To swap a Pad from another Kit:

1  Select the Kit you want to start with.

2  Right-click the Pad you want to swap out.

3  From the Replace With pop-up menu, select the 
Kit whose pad you want to use.

Right-clicking a Pad to select from a different Kit.

On Mac, if you do not have a right-click 
mouse you can Ctrl-click any pad for the 
Replace With pop-up menu.
KitCore Guide
Global Pad Settings

You can assign KitCore’s drum pads to multiple 
unique audio output channels for independent 
mixing and audio processing in your DAW. KitCore 
provides 8 stereo output channels (1–2 through 
15–16) and 24 mono output channels. Pad output 
assignments are applied by pad number across all 
kits. Also note that how KitCore’s output channel 
assignment appear as inputs varies between dif-
ferent DAW applications. 

To assign KitCore to multiple outputs:

1  In the KitCore Plug-in window, enable the As-
signable Outputs option in the Global Pad Settings 
pane.

2  Select the Pad whose output you want to assign.

3  From the Pad Output pop-up menu, select the 
desired output assignment (e.g., KC 17).

4  Repeat the preceding steps for each additional 
Pad as desired.

Global Pad Settings

Changes to Pad Output Assignments can 
be saved as plug-in presets in AU, RTAS, 
and VST formats. See “Saving Kits as 
Presets” on page 11.



To assign KitCore outputs to channel inputs in 
your DAW:

■ KitCore outputs are routed to audio inputs in 
your DAW according to how your DAW manages vir-
tual instrument plug-ins with multiple outputs.

Dynamics

KitCore provides VU Meters and a Volume slider to 
monitor and control the master volume. You can 
also adjust the amount of dynamic variation using 
the LiveDrummer slider.

Volume

To adjust KitCore’s Kit Volume:

■ Move the Kit Volume slider to the right to boost 
the Kit volume.

– or –

■ Move the Kit Volume slider to the left to atten-
uate the Kit Volume.

Consult the manufacturer’s documenta-
tion for your DAW for information on 
routing multiple outputs from an in-
strument plug-in to individual tracks in 
your DAW for mixing and processing.

For examples of routing KitCore outputs 
in different DAWs, see “Chapter 4: Us-
ing KitCore in Your DAW” on page 17.

KitCore Volume and VU Meters
LiveDrummer

Whether you are programming your own MIDI 
drum patterns or using KitCore’s MIDI grooves, you 
can use the LiveDrummer slider to add a little va-
riety to the sound. The LiveDrummer slider af-
fects both the velocities and the samples used for 
each event. For example, if you add a series of 
MIDI notes that are all at the same velocity to play 
a hi-hat pad, you can adjust the LiveDrummer 
slider to breathe a little life into it. Experiment 
with this setting to find just the right feel for your 
MIDI grooves and drum patterns.

Saving Kits as Presets
Once you have edited KitCore’s Pad Settings and 
Global Pad Settings, you will probably want to 
save your changes. Use your DAW’s plug-in set-
tings or plug-in presets feature to save the 
changes you have made. For information on how 
to save and manage plug-in presets in your DAW, 
consult the manufacturer’s documentation.
Chapter 3: Using KitCore 11
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Grooves
When you install, KitCore, you not only get Kit-
Core’s sampled drum kits, you also get an exten-
sive library of MIDI files, or “GrooveSets,” that 
you can import into your DAW to play KitCore. 
GrooveSets logically group beats, fills, and varia-
tions of different drum patterns that work well to-
gether. The content reflects the featured drum-
mer's musical sensibilities as they played these 
parts together as one song.

The Grooves tab in KitCore lets you sort, filter, 
and audition KitCore GrooveSets. When you find 
the groove you want, you can drag and drop it 
right into your DAW for further editing and arrang-
ing. Use any combination of KitCore’s extensive li-
brary of MIDI drum patterns and edit them in your 
DAW to get the perfect drum track for any 
project. Once KitCore’s grooves are in your DAW, 
you can use them to play KitCore any of the MIDI 
editing, and audio mixing and processing capabil-
ities that your DAW provides.

KitCore Grooves
KitCore Guide
Drummers and Styles

The Drummer and Styles list lets you sort Kit-
Core’s GrooveSets either by drummer or style. 

To organize grooves by Drummer:

1  Click the Drummers button in the Grooves page. 

2  Click the Reveal Grooves triangle for the drum-
mer you want to show KitCore’s selection of 
GrooveSets sorted by the selected drummer.

3  Select the grooves category you want to view 
the MIDI Grooves in the Grooves List (see “Loops 
and Fills” on page 13).

Drummer list

Reveal grooves



To organize grooves by Style:

1  Click the Styles button in the Grooves page. 

2  Click the Reveal Grooves triangle for the style 
you want to show the GrooveSets available by the 
selected style.

3  Select the grooves category you want to view 
the MIDI Grooves in the Grooves List (see “Loops 
and Fills” on page 13).

Loops and Fills

Once you have selected the groove category you 
want in the Drummers or Styles List, you can filter 
the Grooves list to view only loops, only fills, or 
both loops and fills. 

Select any groove in the list to view its metadata, 
audition it, or drag and drop it into your DAW.

Styles list

Reveal grooves
To show both Loops and Fills:

1  Click the Loops button so that it is highlighted.

2  Click the Fills button so that it is also high-
lighted.

To show only Loops:

1  Click the Loops button so that it is highlighted.

2  Click the Fills button so that it is not high-
lighted.

To show only Fills:

1  Click the Fills button so that it is highlighted.

2  Click the Loops button so that it is not high-
lighted

Grooves list, Loops and Fills
Chapter 3: Using KitCore 13
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Groove Metadata

When a groove is selected in the Grooves list, the 
metadata for that groove is displayed along with 
an overview of the pattern.

MIDI Groove Overview Provides a visual repre-
sentation of the MIDI drum pattern.

Playhead Indicator indicates the playhead loca-
tion in the MIDI Groove overview when auditioning 
a groove.

Groove Name and Original Tempo Displays the 
name of the groove and its original tempo (in 
BPM).

Feel Displays the rhythmic feel of the groove.

Meter Displays the meter of the groove.

Tempo Displays the current playback tempo as set 
in your DAW.

Duration Displays the duration of the groove in 
bars.

Groove overview and metadata

Playhead indicator

MIDI Groove overview
Groove name

and original tempo

Playback tempo
KitCore Guide
Auditioning Grooves

You can audition any of KitCore’s grooves before 
importing them into your DAW.

To audition a groove:

1  Select the groove you want to audition in the 
Grooves list.

2  Click the Play button. The groove plays the Cur-
rent Kit at the current playback tempo as set in 
your DAW.

3  Select other grooves in the Grooves list to audi-
tion them.

4  Click the Stop button to stop auditioning the se-
lected groove.

Queue Play Mode

The Queue Play Mode toggle enables (or disables) 
Queue Play Mode. When Queue Play Mode is en-
abled, you can select a second groove to start 
playback as soon as the currently selected groove 
finishes playing. When Queue Play Mode is dis-
abled, any newly selected groove begins playing 
immediately, cutting off playback of the previ-
ously selected groove.

Groove audition controls

Groove audition controls



Filtering Grooves

You can filter grooves shown in the Grooves list by 
feel. This can help you find the right groove with 
the right rhythmic feel quickly and easily.

To filter what grooves are shown in the Grooves 
list:

1  Click the Show pop-up menu and select the 
rhythmic feel you want.

Only groove with the matching Feel metadata are 
shown in the Grooves list. Select All to show all 
grooves regardless of feel.

Groove filter pop-up menu
Exporting MIDI Grooves to Your 
DAW

KitCore makes it easy to export grooves from Kit-
Core to your DAW. Once you have located the 
groove you want, simply drag and drop it to your 
DAW. Once you have imported a KitCore groove 
into your DAW, you can edit it and arrange it as 
you like and use that MIDI data to play KitCore’s 
Drum Kits.

To export a groove from KitCore to your DAW:

1  Select the groove you want to export in the 
Grooves list.

2  Click and drag the groove from the Grooves list 
or from the MIDI Groove overview to your DAW.
Chapter 3: Using KitCore 15
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KitCore Settings
The KitCore Settings tab in the KitCore Plug-in lets 
you select whether to use the KitCore or Drum-
Core Data location (if DrumCore is installed), and 
provides access to information about KitCore and 
KitCore registration.

To select the KitCore or DrumCore Data location 
for use with KitCore:

1  Select the Settings tab. By default, the Use Kit-
Core Default Data Folder option is enabled. 

2  If DrumCore is installed on your computer, you 
can select the Use DrumCore Data Folder option.

KitCore Settings
KitCore Guide
To register KitCore:

1  Select the Settings tab.

2  Click the Register button.

3  In the Register KitCore dialog, enter your Name 
and Serial Number if necessary.

4  Click the Generate Challenge Code button.

5  Click the link to register at www.submersible-
music.com.

6  Enter the response code you receive from 
www.submersiblemusic.com into the Response 
Code field in the Register KitCore dialog.

7  Click Authorize.



CHAPTER 4: Using KitCore in Your DAW
Every Digital Audio Workstation (DAW) is a little 
different in how it manages virtual instrument 
plug-ins—including how MIDI is routed to the plug-
in and how audio is routed from the plug-in 
through the DAW’s mixer. For the most accurate 
and up to date information on using virtual instru-
ment plug-ins, like KitCore, consult the documen-
tation for your DAW. However, this section does 
provides a few examples: using KitCore with 
Pro Tools, Ableton Live, Digital Performer, Cu-
base, Logic, Acid, and Sonar.
Chapter 4: Using KitCore in Your DAW 17
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Pro Tools Example
Figure 1 shows an example of a Pro Tools session with KitCore inserted on an Instrument track, and with 
the Kick, Snare, High-Hat, and Ride Cymbal Pads assigned to separate outputs for individual mixing and 
processing on separate Auxiliary Input tracks.
KitCore Guide
Figure 1.  Example of a Pro Tools session with different KitCore Pads assigned to different outputs



Configuring Pro Tools to Monitor 
Multiple Outs from KitCore

To route KitCore outputs to multiple Pro Tools 
tracks for independent mixing and processing:

1  Create a new stereo Instrument track.

2  Insert the KitCore RTAS plug-in on that track.

3  In the KitCore plug-in window, assign different 
pads to different KitCore output channels 
(see“Global Pad Settings” on page 10). 

For example, select the Kick 1 pad and assign it to 
KitCore Output “Mono 17,” the snare pads to 
“Mono 18,” and the high hat pads to “Mono 19.”

4  In Pro Tools, create 3 new mono Auxiliary Input 
tracks.

5  For the first new Auxiliary Input track, select 
Plug-in > KitCore > KC 17 from the track’s Input se-
lector.
6  Set the remaining Auxiliary Input tracks to KC 18 
and KC 19 respectively.

You can now mix and process outputs 17, 18, and 
19 from KitCore independently using mix automa-
tion and plug-ins on the Auxiliary Input tracks.

Exporting Grooves from KitCore to 
Pro Tools

You can drag a groove from KitCore and drop it to 
the Pro Tools Timeline, an exisiting Instrument or 
MIDI track, or to the Region List.

To export a groove from KitCore to Pro Tools:

1  Select the groove you want to export in the 
Grooves list.

2  Click and drag the groove from the Grooves list 
or from the MIDI Groove overview to the Instru-
ment track on which Kit Core is inserted (see 
Figure 2 on page 20).

To play the KitCore plug-in in Pro Tools, 
import KitCore MIDI content into your 
Pro Tools session (see “Exporting 
Grooves from KitCore to Pro Tools” be-
low), play your external MIDI controller, 
or create your own MIDI drum sequence.
Chapter 4: Using KitCore in Your DAW 19
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Figure 2.  Dragging and dropping a KitCore groove to a Pro Tools Instrument track



Ableton Live Example
Figure 3 shows an example of a Live set with KitCore inserted on a MIDI track, and with the Kick, Snare, 
and High-Hat Pads assigned to separate outputs for individual mixing and processing on separate audio 
tracks.
Figure 3.  Example of a Live set with different KitCore Pads assigned to different outputs
Chapter 4: Using KitCore in Your DAW 21
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Configuring Live to Monitor 
Multiple Outs from KitCore

To route KitCore outputs to multiple audio 
tracks in Live for independent mixing and 
processing:

1  In your Live set, create a new MIDI track.

2  Drag and drop the KitCore plug-in from the Plug-
in Device Browser to the MIDI track.

3  In the KitCore plug-in window, assign different 
pads to different KitCore output channels 
(see“Global Pad Settings” on page 10). 

For example, select the Kick 1 pad and assign it to 
KitCore Output “Mono 17,” the snare pads to 
“Mono 18,” and the high hat pads to “Mono 19.”

4  In Live, create 3 new audio tracks.

5  For the first new audio track, select Audio From 
> 1-MIDI.
KitCore Guide
6  From the track’s Input Channel selector, select 
KC 17-KitCore.

7  Set the remaining audio track inputs to KC 18-
KitCore and KC 19-KitCore respectively.

You can now mix and process outputs 17, 18, and 
19 from KitCore independently using mix automa-
tion and plug-ins on the audio tracks.

To play the KitCore plug-in in Live, im-
port KitCore MIDI content into your Live 
set (see “Exporting Grooves from KitCore 
to Live” on page 23), play your external 
MIDI controller, or create your own MIDI 
drum sequence.



Exporting Grooves from KitCore to 
Live

You can drag a groove from KitCore and drop it to 
a MIDI track.
To export a groove from KitCore to Live:

1  Select the groove you want to export in the 
Grooves list.

2  Click and drag the groove from the Grooves list 
or from the MIDI Groove overview to the MIDI 
track for KitCore (see Figure 4 below).
Figure 4.  Dragging and dropping a KitCore groove to a Clip in Live
Chapter 4: Using KitCore in Your DAW 23
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Digital Performer Example
Figure 5 shows an example of a Digital Performer Project playing the KitCore AU plug-in.
KitCore Guide
Figure 5.  Example of a Digital Performer project playing KitCore
Configuring Digital Performer to 
Monitor Multiple Outs from KitCore

To route KitCore outputs to multiple Aux tracks 
in Digital Performer for independent mixing and 
processing:

1  In your Digital Performer Project, create a new 
Instrument track with KitCore by selecting Project 
> Add Track > Instrument Track > Submersible Mu-
sic: KitCore (mono or stereo).

2  Create a new MIDI track by selecting Project > 
Add Track > MIDI Track.
3  From the MIDI track’s Output menu, select Kit-
Core-1-1. 

4  Import KitCore MIDI content to the MIDI track 
(see “Exporting Grooves from KitCore to Digital 
Performer” on page 25), play your external MIDI 
controller, or create your own MIDI drum sequence 
to play KitCore in Digital Performer.

5  In the KitCore plug-in window, you can assign 
different pads to different KitCore output chan-
nels (see“Global Pad Settings” on page 10). 



For example, select the Kick 1 pad and assign it to 
KitCore Output “Mono 17,” the snare pads to 
“Mono 18,” and the high hat pads to “Mono 19.”

6  In Digital Performer, create a new Aux track by 
selecting Project > New Track > Aux Track.

7  From the Aux track’s Input menu, select New 
Mono Bundle > KitCore-1 17. (You may need to 
configure this in the Bundles window first.)

8  Repeat steps 5 through 7 to route additional Kit-
Core outputs to separate Aux tracks for mixing 
and processing.

You can now mix and process outputs 17, 18, and 
19 from KitCore independently using mix automa-
tion and plug-ins on the Aux tracks.
Exporting Grooves from KitCore to 
Digital Performer

You can drag a groove from KitCore and drop it to 
a MIDI track.

To export a groove from KitCore to Digital 
Performer:

1  Select the groove you want to export in the 
Grooves list.

2  Click and drag the groove from the Grooves list 
or from the MIDI Groove overview to the MIDI 
track for KitCore (see Figure 6 below).

To play the KitCore plug-in in Digital 
Performer, import KitCore MIDI content 
into your Digital Performer project (see 
“Exporting Grooves from KitCore to Dig-
ital Performer” below), play your ex-
ternal MIDI controller, or create your 
own MIDI drum sequence.
Figure 6.  Dragging and dropping a KitCore groove to MIDI Track in Digital Performer
Chapter 4: Using KitCore in Your DAW 25
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Cubase Example
Figure 7 shows an example of a Cubase Project with a MIDI track playing the VST Instrument KitCore on 
an Instrument track.
KitCore Guide
Figure 7.  Example of a Cubase Project playing KitCore



Configuring Cubase with KitCore

To play KitCore in your Cubase Project:

1  Create a new Instrument track by going to the 
Devices menu and selecting VST Instruments.

2  In the VST Instruments window, select KitCore 
as the VST Instrument.

3  When prompted to create a new MIDI track as-
signed to KitCore, click Create.

4  Import KitCore MIDI content to the new MIDI 
track (see “Exporting MIDI Grooves to Your DAW” 
on page 15), play your external MIDI controller, or 
create your own MIDI drum sequence to play Kit-
Core in Cubase.
5  Choose the Output Activation list for KitCore in 
the VST Instruments rack and select however 
many separate outputs you want to use. This will 
create multiple audio tracks in Cubase. 

6  Assign the outputs for pads in KitCore that cor-
responding to each audio track in Cubase accord-
ingly (see Figure 8 below).
Figure 8.  Assigning the Snare pad output to Stereo 3–4 to play through the corresponding audio track in Cubase
Chapter 4: Using KitCore in Your DAW 27
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Logic Example
Figure 9 shows an example of a Logic Song with KitCore inserted on an Instrument track.
KitCore Guide
Figure 9.  Example of KitCore in Logic
Configuring Logic with KitCore

To play KitCore in Logic:

1  Create a new Instrument track in Logic by se-
lecting New from the Track menu. 

2  Select Software Instrument for the Type and 
click Create.
3  Insert KitCore on the Instrument track as a ste-
reo plug-in. The KitCore plug-in window opens.

4  Import KitCore MIDI content to the Instrument 
track (see “Exporting MIDI Grooves to Your DAW” 
on page 15), play your external MIDI controller, or 
create your own MIDI drum sequence to play Kit-
Core in Logic.

Inserting KitCore as a stereo instrument plug-in



Configuring Logic to Monitor 
Multiple Outs from KitCore

To route KitCore outputs to multiple Aux tracks 
in Logic for independent mixing and processing:

1  Insert KitCore on the Instrument track as a mul-
tichannel plug-in. The KitCore plug-in window 
opens.

2  Select Options > Create New Auxiliary Channel 
Strips in the Logic Mixer.

Inserting KitCore as a multichannel instrument plug-
in
3  Type the number for however many separate 
channels you want to mix from KitCore in Logic, 
set the Format (mono or stereo) and click Create.

4  Assign the outputs for pads in KitCore as de-
sired.

5  Set the Inputs for the Auxiliary Channel Strips to 
the desired KitCore outputs.

Assigning KitCore outputs to Auxiliary Channel Strip 
inputs
Chapter 4: Using KitCore in Your DAW 29
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ACID Example
Figure 10 shows an example of KitCore in Sony ACID Pro.
KitCore Guide
Figure 10.  Example of KitCore in ACID



Configuring ACID with KitCore

To play KitCore in ACID:

1  In ACID, select Soft Synth from the Insert menu.

2  In the resulting Soft Synth dialog, select KitCore 
and click OK.

3  Drag and drop grooves from KitCore to a MIDI 
track in ACID (see “Exporting MIDI Grooves to Your 
DAW” on page 15). You can also drag and drip Kit-
Core grooves to a blank space in the project track 
area to create a track automatically. 
4  Assign the MIDI track output the MIDI track to 
KitCore (see Figure 11 below).

You can also play KitCore by routing MIDI from 
your external MIDI controller through the MIDI 
track that is assigned to KitCore or by program-
ming your own drum patterns on that MIDI track.
Figure 11.  Assigning the MIDI track output to KitCore
Chapter 4: Using KitCore in Your DAW 31



32
Sonar Example
Figure 12 shows an example of Sonar with a MIDI track playing the VST Instrument KitCore on an Instru-
ment track.
KitCore Guide
Figure 12.  Example of a Sonar playing KitCore



Configuring Sonar with KitCore

To play KitCore in Sonar:

1  In Sonar, select Insert > Soft Synth > vstplugins 
> KitCore.

2  In the Insert Soft Synth Options dialog, select 
the First Synth Audio Output option to use the 
main stereo outs from KitCore.

3  Click OK. Sonar creates both a new stereo audio 
track and a new MIDI track

4  Drag and drop grooves from KitCore to the MIDI 
track in Sonar that is assigned to KitCore (see “Ex-
porting MIDI Grooves to Your DAW” on page 15). 

You can also play KitCore by routing MIDI from 
your external MIDI controller through the MIDI 
track that is assigned to KitCore or by program-
ming your own drum patterns on that MIDI track.
Configuring Sonar to Monitor 
Multiple Outs from KitCore

To route KitCore outputs to multiple audio 
tracks in Sonar for independent mixing and 
processing:

1  In Sonar, select Insert > Soft Synth > vstplugins 
> KitCore.

2  In the Insert Soft Synth Options dialog, select ei-
ther or both the All Synth Audio Outputs: Stereo 
and the All Synth Audio Outputs: Mono options to 
use multiple stereo and/or mono outs from Kit-
Core. 

3  Click OK. Sonar creates multiple new stereo 
and/or mono audio tracks, and a single new MIDI 
track.

4  Assign the outputs for pads in KitCore that cor-
responding to each audio track in Sonar accord-
ingly (see Figure 13 on page 34).
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Figure 13.  Assigning the Snare pad output to Stereo 3–4 to play through the corresponding audio track in Sonar
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